Elevated API Latency
Incident Report for OpenSea
Resolved
This incident has been resolved.
Posted Apr 27, 2022 - 22:31 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 27, 2022 - 22:07 UTC
Investigating
We're experiencing an elevated level of API latency and are currently looking into the issue.
Posted Apr 27, 2022 - 21:28 UTC
This incident affected: API, Website, and Mobile Application.