Polygon Sale Events Delayed
Incident Report for OpenSea
Resolved
Polygon sale events are processing properly again
Posted Jul 11, 2023 - 18:11 UTC
Investigating
We are currently investigating delayed sale event processing on Polygon
Posted Jul 11, 2023 - 17:51 UTC