OpenSea platform is experiencing delayed response times
Incident Report for OpenSea
Resolved
This incident has been resolved.
Posted Nov 08, 2021 - 13:51 UTC
Monitoring
A fix has been implemented and platform response time are back to normal. We are continuing to monitor.
Posted Nov 07, 2021 - 23:36 UTC
Investigating
We are experiencing elevated levels of platform response time and currently investigating.
Posted Nov 07, 2021 - 23:07 UTC
This incident affected: API, Website, and Mobile Application.