Blockchain Processing Delays

Incident Report for OpenSea

Resolved

This incident has been resolved.
Posted Mar 05, 2022 - 06:11 UTC

Investigating

Our upstream blockchain data provider is unavailable, which is causing the website and API to reflect stale data. Orderbook information and asset ownership changes may be delayed.
Posted Mar 05, 2022 - 05:57 UTC
This incident affected: API, Website, Mobile Application, and Emails.