Developer Testnet Chain Mumbai Down
Incident Report for OpenSea
Resolved
The Mumbai developer testnet is operational again.
Posted Oct 07, 2021 - 14:02 UTC
Investigating
Polygon's development testing chain (Mumbai) has not had any new blocks detected since Oct-06-2021 02:33:31 PM +UTC. This does not affect the main Polygon network.
Posted Oct 06, 2021 - 21:14 UTC
This incident affected: Developer Testnets (Chain - Mumbai).