Database Issues
Incident Report for OpenSea
Resolved
This incident has been resolved.
Posted Apr 04, 2022 - 17:50 UTC
Investigating
The site is currently experiencing database connection issues. We are investigating the issue.
Posted Apr 04, 2022 - 17:28 UTC
This incident affected: API, Website, and Mobile Application.