OpenSea platform is experiencing delayed response times
Incident Report for OpenSea
Resolved
This incident has been resolved.
Posted Mar 29, 2022 - 18:37 UTC
Investigating
We are currently investigating this issue.
Posted Mar 29, 2022 - 17:35 UTC
This incident affected: API and Website.