Testnets Outage

Incident Report for OpenSea

Resolved

This incident has been resolved.
Posted Apr 18, 2022 - 20:36 UTC

Investigating

testnets.opensea.io is currently experiencing issues. We are investigating the issue.
Posted Apr 18, 2022 - 20:26 UTC
This incident affected: Developer Testnets (Testnets API).