The incident has been resolved
Incident Report for OpenSea
Resolved
This incident has been resolved
Posted Dec 20, 2023 - 16:45 UTC
Investigating
We are investigating reports of degraded performance on the OpenSea website
Posted Dec 20, 2023 - 14:32 UTC