Blockchain Processing Delays
Incident Report for OpenSea
Resolved
This incident has been resolved.
Posted Apr 25, 2022 - 02:08 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 25, 2022 - 02:04 UTC
Investigating
There is an issue with our upstream blockchain data provider which has caused the website and API to reflect stale data. NFT ownership changes may be delayed.
Posted Apr 25, 2022 - 01:46 UTC
This incident affected: Alchemy API.