The OpenSea website is experiences an outage
Incident Report for OpenSea
Resolved
The incident has been resolved
Posted Jul 25, 2023 - 12:21 UTC
Investigating
We are investigating issues when visiting any page on opensea.io
Posted Jul 25, 2023 - 12:13 UTC