Ethereum Activity Delay
Incident Report for OpenSea
Resolved
This incident has been resolved
Posted Oct 19, 2021 - 22:16 UTC
Investigating
We are currently investigating an issue in which our website is not properly fetching the latest Ethereum transactions. The activity feed on the website will be impacted for the time being.
Posted Oct 19, 2021 - 21:47 UTC