The OpenSea website is experiencing degraded performance

Incident Report for OpenSea

Resolved

This incident has been resolved.
Posted 2 years ago. Aug 02, 2023 - 16:41 UTC

Update

We have identified the cause and have resolved this issue.
Posted 2 years ago. Aug 02, 2023 - 16:40 UTC

Investigating

We are investigating reports of degraded performance on the OpenSea website
Posted 2 years ago. Aug 02, 2023 - 15:45 UTC