A third party vendor outage is impacting the OpenSea website
Incident Report for OpenSea
Resolved
This incident has been resolved
Posted Aug 22, 2023 - 21:05 UTC
Investigating
We are investigating reports of a third party vendor outage that is impacting the OpenSea website
Posted Aug 22, 2023 - 20:41 UTC