website-api-partial-outage
Incident Report for OpenSea
Resolved
Website and REST api issues are resolved.
Posted May 22, 2023 - 20:26 UTC
Investigating
We are currently investigating the issue
Posted May 22, 2023 - 18:38 UTC