The OpenSea website is experiencing degraded performance

Incident Report for OpenSea

Resolved

This incident has been resolved
Posted Jul 20, 2023 - 14:47 UTC

Identified

We have identified the issue and are working on implementing mitigations
Posted Jul 20, 2023 - 14:01 UTC

Investigating

We are investigating reports of degraded performance on the OpenSea website
Posted Jul 20, 2023 - 11:30 UTC